PLOP and PLOP DS 5.1

This version is outdated!

This version is outdated. It is offered only for customers who need download packages for an existing license. Please use the navigation menu to locate current product releases.

Download PDFlib PLOP & PLOP DS 5.1

All PLOP packages contain combined binaries which cover two products:

  • PLOP is a versatile tool which can repair, linearize, optimize, encrypt, and decrypt PDF documents.
  • PLOP DS (Digital Signature) offers all features of PLOP, plus the ability to apply digital signatures to PDF documents. The digital signature feature is only available in PLOP DS, but not in the PLOP base product.

English PLOP & PLOP DS documentation is included in each of the packages. Technical documentation in languages different from English can be found below the download table.

PDFlib PLOP and PLOP DS packages contain:

  • the command-line program
  • the library for the languages noted
  • the documentation
  • examples for all supported languages

PDFlib PLOP / PDFlib PLOP DS 5.1 (released 05/2016)

PlatformsPackage for use with
Windows - see system requirements
Windows Server x86 and
Windows XP/Vista/7/8/10 on x86
COM .NET, C, C++, Java, Perl, PHP, Python, Ruby
Windows Server (64-bit)
and Windows XP/Vista/7/8/10 (64-bit) on x64
COM .NET, C, C++, Java, Perl, PHP, Python
OS X/macOS - see system requirements
OS X/macOS 10.6 and above on x86/x64C, C++, Java, Perl, PHP, Python, Ruby
Linux/FreeBSD- see system requirements
Linux on IA-32 (for Intel x86)C, C++, Java, Perl, PHP, Python, Ruby
Linux on Intel 64C, C++, Java, Perl, PHP, Python, Ruby
FreeBSD 7/8/9/10 x86C, C++, Java, Perl, PHP, Python, Ruby
FreeBSD 7/8/9/10 Intel 64C, C++, Java, Perl, PHP, Python, Ruby
Mobile and Embedded Systems - system requirements
iOSObjective-C, C, C++
AndroidC, C++Java
Oracle/HP/IBM - see system requirements  
Oracle Solaris on sparcC, C++, Java, Perl, PHP, Python, Ruby
Oracle Solaris on sparc (64-bit)C, C++, Java
Oracle Solaris on x86C, C++, Java, Perl, PHP, Python, Ruby
Oracle Solaris on x64C, C++, Java
HP-UX 11 on IA-64 (ILP32)C, C++, Java, Perl, PHP
HP-UX 11 on IA-64 (LP64)C, C++, Java, PHP
IBM AIX 5/6/7

C, C++, Java, Perl, PHP, Python

IBM AIX 5/6/7 (64-bit)C, C++, Java
IBM i5/iSeries and zSeries - see system requirements  
IBM i5/iSeries1 
IBM zSeries (USS)C, C++, Java

1) See here regarding the use of AIX binaries for Java or PHP for deployment on IBM i5/iSeries.

 

  • PHP 5.4, 5.5, 5.6 and 7.0 is supported (not all versions are available on all platforms). See our PDFlib in PHP HowTo document for more info about PHP and PDFlib products.
  • For .NET please see our document PDFlib in .NET HowTo.
  • Perl 5.8, 5.18, 5.20 and 5.22 is supported.
  • Python 2.5, 2.6, 2.7, 3.2, 3.3 and 3.4 is supported.
  • Ruby 2.0, 2.1, 2.2 and 2.3 is supported.

If you want to check that your download was free of transmission errors, we provide md5 checksums for all download packages.

PDFlib PLOP & PLOP DS Documentation

The PDFlib PLOP & PLOP DS Reference Manual provides a thorough introduction to programming with PDFlib PLOP and the complete PLOP API. It is a must-read for all PLOP developers.

PDFlib PLOP & PLOP DS
PDFlib PLOP & PLOP DS Reference ManualThe English edition of the PDFlib PLOP & PLOP DS 5.1 Reference Manual is included in all PLOP 5.1 packages.
pCOS Path ReferenceEnglish Path Reference for pCOS interface 11 in PDFlib PLOP & PLOP DS 5.1
PDFlib PLOP & PLOP DS ReferenzmanualGerman PDFlib PLOP & PLOP DS 5.1 Reference Manual
pCOS PfadreferenzGerman Path Reference for pCOS interface 11 in PDFlib PLOP & PLOP DS 5.1
PDFlib PLOP & PLOP DS Reference ManualJapanese PDFlib PLOP & PLOP DS 5.1 Reference Manual
pCOS Path ReferenceJapanese Path Reference for pCOS interface 11 in PDFlib PLOP & PLOP DS 5.1